Еще раз об установке DRUSH

Для управление инсталляциями Drupal часто используют иструмент Drush/ Он активно развивается и в связи с этим необходимо следить за способами установки и обновления его на разных платформах и хостингах.
Обязательно необходимо сверятся с таблицей "Совместимость с Drupal" - ]]>https://docs.drush.org/en/8.x/install/]]>

Установка drush бывает глобальной, то есть чтобы все пользователи сервера могли им пользоваться, и локальной этот вариант больше подходит для шаред хостингов, когда пользователь, который установил сможет им пользоваться.

Установка глобального drush

Для начала необходимо установить composer, для это выполняем команды:

sudo apt-get install curl php7-cli
cd ~
curl -sS https://getcomposer.org/installer 
sudo php installer --version=*.*.* --install-dir=/usr/local/bin --filename=composer
php composer self-update
Установка drush с помощью composer
# Создаем директорию для установки Drush и переходим в нее. 
mkdir --parents /opt/drush 
cd /opt/drush 
# Инициализация проекта Composer, с указанием зависимости Drush. 
composer init --require=drush/drush:8.*
# Настраиваем путь для бинарных файлов Drush. 
composer config bin-dir /usr/local/bin 
# Установка Drush. 
composer install 

Для обновления drush необходимо указать версию drush в файле /opt/drush/composer.json и выполнить команды:

cd /opt/drush
composer update

Установка локального drush

Для начала требуется установить composer командами:

cd ~
php -r "readfile('https://getcomposer.org/installer');" | php
mv composer.phar bin/composer.phar
php composer self-update

Для установки drush выполняем команду:

composer global require drush/drush:8.*

Для запуска drush в любой папке необходимо добавить в конец файла ~/bash_profile следующие строки:
export PATH="$HOME/.composer/vendor/bin:$PATH"
alias composer='~/bin/composer.phar'
alias drush="~/.composer/vendor/bin/drush"

Для разных систем может потребоваться изменить пути к файлам или просто создать симлинки на исполняемые файлы.

После этого закрыть ваш SSH клиент и войти в систему снова. Для обновления версии drush необходимо выполнить команду:

composer global require drush/drush:8.*


Сейчас на сайте

Пользователей онлайн: 0.

Пользователи

  • charleshicktw
  • jester001
  • Petr
  • snn
  • abobis
  • happyuser
  • ufabet เว็บตรงท...
  • jthtrhhtrh11
  • aglobe
  • nik-s1